- More about the functions in LSS

Managing welcome messages

Manage welcome messages to be displayed on the TV widget by language. To manage welcome messages by language, select a
language from the Select Language dropdown list.

Welcome message title settings

1 Enter a welcome message title in the Welcome Title field.

— A welcome message title can be up to 30 characters long.
) Select a location to display the title from Center/Left/Right.

3 To save the changes, click Save.

Welcome message content settings

1 Enter the content of a welcome message in the Welcome Message field.

— The content of a welcome message can be up to 500 characters long.
) Select a location to display the message from Center/Left/Right.

3 To save the changes, click Save.



- More about the functions in LSS

Currency unit settings

1 To specify the currency unit to be displayed on Express checkout bills, select a language from the Select Language
dropdown list.

) Enter a unit in the Monetary Unit field.
3 Select alocation to display the unit from Left/Right.

4 To save the changes, click Save.

Managing Express checkout messages

Manage Express checkout result messages for guests by language. To manage Express checkout messages by language, select a
language from the Select Language dropdown list.

Check-out success message settings

1 To specify the message to be displayed on TVs when Express checkout is successful, enter a message in the success Message
field.

) Select alocation to display the message from Center/Left/Right.

3 To save the changes, click Save.

Check-out failure message settings

1 To specify the message to be displayed on TVs when Express checkout fails, enter a message in the Failure Message field.
) Select a location to display the message from Center/Left/Right.

3 To save the changes, click Save.



Special feature settings for 2014 widgets

Set the remote control hot key feature and the select channel feature. These features are provided only to 2014 widgets.
1 To set special features provided to 2014 widgets, click Setup > Configurables.

) Fillin the required input fields and click Save.

Setup Commeon Language

Loaded Project

Red Hotkey

Green Hotkey

Yellow Hotkey

Blue Hotkey

Power On IP O Yes ® No
Loaded Project View the widget type currently loaded.
Red Hotkey Set the feature to run when the red button is pressed on the remote control.
Green Hotkey Set the feature to run when the green button is pressed on the remote control.
Yellow Hotkey Set the feature to run when the yellow button is pressed on the remote control.
Blue Hotkey Set the feature to run when the blue button is pressed on the remote conttrol.

= Yes: Set the IPTV channel info to be displayed as the first page when aroom TV is
turned on.

Power On IP

= No: Set the main page of the selected widget type to be displayed as the first page
when aroom TV is turned on.



Monitoring

To view the TV network status and the room occupancy status, click Monitoring from the menu bar at the top.

= The Monitoring window will appear.

Monitoring

Interval: [EXTGRRG 2.0/Sec [Lastupdate. 13:12:10] (0.3) Stop

® OK/ Occupied Fail / Empty

Specify the monitoring update cycle using the dropdown list.

* The default cycle is set to Auto.

9 View the last monitoring update time. Click Stop if you want to stop monitoring.

9 View the room number, network status and check-in status for a TV connected to LSS.

If monitoring update has not been performed properly, click Sync to manually sync with PMS.

0 Note

PMS (Property Management System) refers to a hotel room management system. The system connects to LSS to provide necessary
information for hotel room management.



TV settings

To connect and manage a TV from LSS, first configure the TV settings. Configure the TV settings following the instructions below:

Note

The menu names, pages, or paths may vary depending on the TV model.

TV network settings

To connect a TV to LSS, make sure to configure the TV network settings.
Turnon theTV.

Press Mute > 1 >1>9 > ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.

Select Network > Network Setup from the TV default settings menu.

MAIN:Opin, MODE:NONE, RES:NOSIGNAL, Standalone Menu

SI Veendor OFF Widget
Power On Sevice
Channel

Menu 0SD

Operation

Clock

Music Mode

External Device

External Source

Bathroom Speaker

Eco Solution

Logo/Message

When Complate, power down TV.




4 Select Network > Network Settings from the displayed network settings menu.

Network

Network Status

Network Settings
<

soft AP
- Network

AliShare Settings

Device Name [TV] Samsung

5 From the network settings page, select a network type (wired/wireless) and click Connect.

Wireless

VO
Ve v Wired m

6 Select IP Settings from the displayed network connection information page.

— The IP settings page will appear.



From the IP settings page, specify the IP settings including the TV IP address and subnet mask.

— Select Obtain automatically from IP Setting if you want the IP settings to be configured automatically. Select Enter
manually if you want to configure the IP settings manually.

Note

It is recommended to select Enter manually from IP Setting and manually configure the IP settings using a desired IP address.

IP Settings

IP Setting Enter manually

IP Address 123.456.7.89
Subnet Mask 100.100.100.0

Gateway 900.800.9.8

DNS Setting Enter manually
DNS Server 100.200.1.2

Cancel

Select OK to save the configured IP settings.

— The TV network settings are complete.



LSS IP settings required to connect TVs

After configuring the TV network settings, configure the LSS settings to enable LSS to recognize the TV. After configuring the
connection settings, it is possible to manage a TV after TV connection approval from LSS.

Turn on the TV.

Press Mute > 1> 1>9 > ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.

Select Widget > License Server IP Setting from the TV default settings menu.

MAIN:Opin, MODE:NONE, RES:NOSIGNAL, Standalone Menu

Hospitality Mode Standalone Network
ST Vendor OFF

Power On Sevice
Channel

Menu 0SD

Operation

Clock

Music Mode

External Device
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Eco Solution
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[ols

When Complate, power down TV.

In the displayed LSS IP settings page, enter the LSS IP address to be connected to the TV. Set the port number to 444.

Edit Sever IP

Server 1P :

Server Port Number :

<» Move @» Number (¥ Enter 'O Return

Select Enter to save the configured IP settings.

— The LSS settings from the TV are complete. LSS can recognize the TV now.



LSS IP settings required to distribute projects

Configure the LSS connection settings. Connection settings are required to distribute projects (widgets), IPTV channel groups or
messages from LSS to TVs.

Turn on the TV.

Press Mute > 1> 1>9 > ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.

Select Widget from the TV default settings menu.

MAIN:Opin, MODE:NONE, RES:NOSIGNAL, Standalone Menu

Hospitality Mode Standalone Network
ST Vendor OFF

Power On Sevice
Channel

Menu 0SD
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Music Mode

External Device

External Source

Bathroom Speaker

Eco Solution
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[ols

When Complate, power down TV.

Configure the following settings from the displayed widget settings menu.
— Set Widget Mode to ON.

— Set Solution Type to SINC Server.

— To use IPTV, set IPTV Mode to ON.

Note

Set IPTV Mode to OFF if you do not want to use IPTV channels. If OFF is selected for a TV, none of the IPTV channel settings configured from LSS
will be applied to the TV.

— Set Virtual Standby to ON or OFF.

Note

To reduce the time it takes to boot a TV, set Virtual Standby to ON. If Virtual Standby is set to ON, power consumption can increase.



MAIN:Option, MODE:NONE, RES:NOSIGNAL, Standalone Menu

Solution Type SINC Server
ServerURL Setting

License Server IP Setting

IPTV Mode

Virtual Standby

Room Num Setting

When complate, power down TV.

Select ServerURL Setting from the widget settings menu.

When the LSS IP settings screen appears, enter "http: //LSS IP address/browser" or "https: //SINC domain name.s-
hospitalitysolution.net:port number/browser" (e.g., https: //sinc.s-hospitalitysolution.net:444/browser) in the address input
window and select Done.

— The settings required to distribute a project are complete.

Note

If a distributed project is not found on a TV, check to make sure that the TV source is set to App TV hospitality Browser.

http://200.200.100.100/browser

< >

Cancel

(LA ML




Tutorial

Creating and distributing projects for VIP rooms

Explore the process to create and distribute TV widgets (projects) from LSS targeting guests staying in hotel VIP rooms.

Note

This tutorial assumes you are using a VIP room TV released in 2012 and the Widget 2012 [01] type.

Activating a menu language

Activate a language to use to configure projects.
1 Click Setup > Language > Language option from the menu bar at the top.

) Select alanguage checkbox and then click Enable from the displayed language activation window.

Select -
Language Main
(Main English) | Language On/Off - Language Template In use H

O English {on) (Main) In use

[ Afrikaans (on)

[ French [on)

Albanizn (of)

[ Amharic (0ff)

Arabic (Off)

[ Bulgarian (off)

Chinese (i0ff)

Croatian (off)

| vain | %
=




3 Click OK in the displayed activation confirmation window.

— The selected language will activate.

Note

The language that will be used to configure projects must be activated before creating a project.

Creating a project

Create a project for VIP rooms.
1 Tocreate a project, click Project Management > New Project at the top left.

) Configure the settings required to create a project from the displayed window.

Note

This tutorial assumes you are using a VIP room TV released in 2012 and the Widget 2012 [01] type.

New Project X

Name: [ VIP widget |

@® Blank O Default

WAERD

Widget 2011 [01] Widget 2012 [01] Widget 2012 [02]

O

=
Widget 2014 [A] Widget 2014 [] Widget 2014 [E]

Select Theme

®Default

v 0K

3 After configuring the required settings, click OK.



4 Click OK in the confirmation window if you want to create the project.

- The main page of the new project will be loaded on the screen.

B 7 =

f»ﬂ Note

For details on the settings required when creating a project, refer to the following: > Creating a project

Menu settings

Configure the menu settings for a VIP Widget project. Click Menu on from the left side of the page.

= The menu editor will appear.

User Menu(6)

Menu 1
Menu 2
Menu 3
Menu 4
Menu 5

Menu 6



textanchor:003_LSS_ENG.indd:_IPHL_Creat Project

Configure the settings for the top-level menus which appear on the main page of a project.
1 Right-click on Menu 1 from the top-level menu names in the menu editor.

) Select Rename from the context menu items.

ibd IR
User Menu(6)

Menul | g Menu [

Menu2 [Rename ()

Active

Menu 3 Add Sub menu I

Menu 4 | Menu Lock I
Menu up

Menu 5 I
Menu down

Menu 6 | Delste [

3 From the menu name settings window, specify the text size and menu name. Click OK.

| Edit Menu

Font Size 21px ¥

Current Title Menu 1

New Title Hotel Information

L

— The menu name will be updated. Specify the names of the other menu items using the same method.

oooana et~ |3 7 [e—

User Menu(6

Hotel Information

Menu 2
Menu 3
Menu 4
Menu 5

Menu 6

Hotel Information

Icon6

App6

© Left/Right [ Enter




4 To add a top-level menu, select a top-level menu name and click [zl from the menu editor.

— Atop-level menu section will be added in the menu editor.

Hotel Information %uu |—|A]Y]

User Menu(7)

Hotel Information
Menu 2
Menu 3
Menu 4
Menu 5

Menu 6

| Edit Menu7

5 Right-click on the new top-level menu section.

f Select Rename from the context menu items to specify the menu name using the previously mentioned steps.

— Configured top-level menus can be found on the main page.

e < | P =

[ &% I

Hotel Information Guest Service TV Channel Attractions

Icon6

App6

O Left/Right [= Enter
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Sub-level/lower sub-level user menu settings

Configure the settings for sub-menus and lower sub-menus that are found under a top-level menu.
1 Right-click on a top-level menu in the menu editor.

) Select Add Sub menu from the context menu items.

v | EAEIED NN

User Menu(7)

Hotel Informat... &0

Guest id Add Menu

TV Channel Rename

Active

rope - [aaa s menuy |
Attractions Menu Lock

Menu up
Setup Menu down

Edit Menu7 | Delet®

— A sub-menu will be created.

e | OEHOEOD

User Menu(8)

Hotel Information @o

| Guest Service o0

47 Edit Menu o0
TV Channel o0
Apps o0
Attractions o0
Setup o0

Edit Menu7 @0
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— Similarly, right-click on a sub-menu and select Add Sub menu if you want to create a lower sub-menu.

e | OEHOEOD

User Menu(9)
Hotel Information (& )
| Guest Service 0
4 Edit Menu Q0
B EditMenu @o
TV Channel 0
Apps ©0
Attractions 0
Setup ©0
Edit Menu? 0

3 Right-click on Edit Menu that has been created.

4 Select Rename from the context menu items to specify the menu name.

Edit Menu X

Font Size
Current Title  |Edit Menu ‘
New Title

Dining ‘




-

— A new menu structure has been created as follows:

I L

User Menu(19)

Hotel Information e 0

| Guest Service 0
Dining @ 0
LB ariske 00

> Continental e 0
The Park View e 0

Spa o0
Activities 00
l Swimming Pool @ o
Arcade e 0
Bil @0
TV Channel @ 0
Apps @0

[~ Attractions @ 0
‘ Surroundings @ o
‘ Downtown @ 0
Setup @0
Service @ 0

Basic menu settings

To use widgets released in 2014, configure basic menus after configuring user menus.

Note

For details on basic menu settings, refer to the following: ~ » Managing basic menus

For details on configuring project menu settings including the menu hierarchy, refer to the following:  » Project menu settings

Main page settings

Configure the main page settings of a TV widget for VIP rooms.

Note

For details on the main page settings such as the default image, text and background music, refer to the following:
» Main page settings for the default widget, Main page settings for the gallery widget



textanchor:003_LSS_ENG.indd:_IPHL_Manage the main menu
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Tutorial

Menu page settings

Configure the settings for the menu pages that will be provided to users.

Specifying the default edit language

Specify the default edit language.
1 Click Setup > Language > Language option from the menu bar at the top.

] Select alanguage checkbox and then click Main from the displayed language selector window.

Language Option b4

Select -
:I::::Iish) ] Language On/Off = Lal:‘llgal.il:ge Template In use H
[ English (on) (Main) In use
& Afrikaans (on) In use
Albanizn (on) Inuse
O  Ambic (on) Inuse
O chinese (o) Inuse
Croatian (on) In use
O French {on) In us=
E  amharic (o) In usa

[  Bulgarian (off) In use i

e Lo Lo

3 Click OK in the displayed setting confirmation window.

— The selected language will be set as the default edit language.

Note

Default edit language refers to a language used to configure images to ensure a consistent language is used when editing menu pages. To use a
variety of languages when editing menus, refer to the following: B Selecting a menu page language
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Tutorial

User menu page template and layout settings

Configure the template and layout settings for a menu page.
1 Click Menu on from the left side of the page.

) Click a menu item from the menu editor.

— The page settings window will appear.

Select Template W renutype | | 18 MenutistType O ocherType.

Full Contents Type. Full Video Type Full Multi Type

= T [ o
JH I B = E= BE BE = ) E=  HE
4 = { —l—l— 1Bl 3 ) — . >
— j [ .
3 i e © i

3 Select a template type to be applied to the page.

— Available template type choices vary depending on the menu type (top-level menu, sub-menu or lower sub-menu).

[ setct Tempate ]

4 Select alayout type to be applied to the page.
- Available layout type choices vary depending on the template type applied to the page.




— After a layout is selected, the detailed menu page settings window will appear as follows:

Layout Edit

Location:[o | x[0 | size: 400 |x[s20 | I~ Keep aspectorgimal rtioof theimace ([ (SN n =

Configure the menu page settings using text and content, such as images, videos and audio.

@ Note

Available content types and the availability of text can vary depending on the selected template and layout.

To insert an image, click the pencil icon above the image section in the menu page settings window.

Layout Edit

Location:[0  |x|0 | Size:[480 |x|520 |I” Keep aspect original ratio of the image ([T (U S n [ vpload |




Tutorial

) Select an image from the content list window. Click OK.

— The selected image will appear in the image section.

Location:[z[x[1_| sie: s |x[520 |~ Keep aspectorgnal rtio o hemace ([ (D i - ]

Edit text

{
\
oL
‘ i Edit text

A

3 Click the text section, and enter text.

oot o et x| | (D D D  i—]

The Representative Hotel Brand of Korea, The Shilla Seoul

4 To change text layout properties, click| %] in the desired text section.

— The selected text section properties such as the location will appear at the top of the menu page settings window.



5 Change the properties such as the text layout location/size, text alignment/size and text color. Click OK.
- The text layout will be updated according to the new settings.

- To cancel changing a layout and go back to the default settings, click Default.

Note

Image and video layouts can be changed using the same method.

[ o e s i ol o1 D D D | E — - |

6 To set the background music, click Upload on the right side of the menu page settings window.

7 Select a music file from the content list window. Click OK.

— The selected music will be set as the menu page background music.

Location:[505|xlo | swe:[a1s |x(ev |[ien [ [20mn [v]lzee] [ (D (D D | 13 [Tasscnss ml‘

8 After configuring the required menu page settings, click Save at the bottom of the page.

0 Click OK in the confirmation window if you want to apply the new settings.

— The new settings will be applied to the menu page.

Note

For details on components of menu pages, refer to the following: B User menu page settings
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Selecting a menu page language

Configure different menu pages for each language by selecting a desired language.
1 Click Setup > Language from the menu bar at the top.

) Select alanguage from the Select Language dropdown list.

3 After configuring the required settings, click Save.

4 Configure menu pages for the selected language.

Note

« A new font for a language can be viewed after the corresponding project is distributed to TVs. To check the updated font when editing menu
pages, distribute the project to TVs.

- Images in menu pages can only be changed using the default edit language. This ensures a consistent language is used. For details on selecting
a default edit language, refer to the following: B Specifying the default edit language



textanchor:006_LSS_ENG.indd:_IPHL_To edit the default language setting

Distributing a project

Settings before distributing a project

To distribute a created VIP Widget project to TVs in VIP rooms, connect the TVs to LSS first.

Configure the required TV connection settings.

Note

For details on TV settings, refer to the following:  » TV settings

Creating a recipient TV group to distribute a project

Projects are distributed by TV group.

Create a recipient group of TVs in VIP rooms to distribute a VIP Widget project to.

1 Click Group > Project Group from the menu bar at the top.

) Click Add below the list of project recipient groups.

3 Configure the settings required to add a group from the displayed window.

Add Project Group X

Group Name : | VIP Group |
() 2011 TV Models (®) 2012-2013 TV Models () 2014-2016 TV Models
&; 0
nselected IP: 1 Selected IP: 1
0 Pv Room w Py Room »
[ 192.168.0.12 2012 192.168.0.13 2013
< >
i Description : | The Project group for the VIP room's TVs |
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Enter a group name for the TVs in VIP rooms.

Select the widget type (Other TV models) used on the TVs in VIP rooms.

To add a VIP room TV to the group, select a TV checkbox and click (3]

To delete a TV from the group, select a TV checkbox and click El

®@® 6 © © @©

Enter a brief description of VIP Group.

4 After configuring the required settings, click OK.
— VIP Group will be added to the list of project recipient groups.

Project Group || ot
| No Group Name - Description ~ | Deployed Project ~ | Deployed Date - | Widget Type -
2 VIP Group The project group for .. - - 2012
a 1 Standard Group The project group for ... DefaultHotel 2013-07-25 14:26 2012

1
s [

Distributing a project

Distribute a VIP Widget project to VIP Group, which is a group of TVs in VIP room:s.
1 Click Deploy > Deploy Project at the top left.

) Select VIP Widget from the displayed project list. Click Next.

Deploy Project [ Select Project > Select Group & Deploy

@ Select one of projects and dick next button.

Total (6) Project Title: l:l ﬂ
No Project Title + | widget Type | Date ~ | Deployed Date ~ ‘Group Name +
@ 6 CEO Widget Widget 2012 [01] 2013.07.25 14:32:20
@ 5 Standard Widget Widget 2012 [01] 2013.07.25 14:29:49
@ 4 VIP Widget Widget 2012 [01] 2013.07.25 13:41:21
(5] 3 2012 B_Type Widget 2012 [02] 2013.01.23 23:47:09
[ 2 2012_A_Type Widget 2012 [01] 2012.01.19 09:14:01
@ 1 DefaultHotel Widget 2011 [01] 2012.01.1821:19:55  2013.07.25 14:26:28 Standard Group

1

iy




Tutorial

3 Select VIP Group from the displayed TV group list. Click Deploy.
— The VIP Widget project can be used as a widget on all TVs in VIP rooms.

— The Deploy button will not appear until a recipient TV group is selected.

Deploy Project [ Selact Project » Select Group & Deploy

@ Click deploy button, then the project wil be deployed to the selected group.

Project title | Widget Type Deploy Status.
VIP Widget Widget 2012
. I —
| mo | Group Name | Deployed Date Deployed Project
2 ‘Standard Group 2013.07.25 14:26:28 Defaulttiotel b

1 WIP Group

Note
Check to make sure that the project has been distributed properly, using the following methods:
- Click Deploy > Project Deploy List on the left side of the page. Check that the VIP Widget project is in the list of distributed projects.

+ Turnon theTVsin VIP rooms and check that the main page of the VIP Widget project is displayed on the TVs.



-

IPTV news channel group settings and distribution

Explore the process to add and distribute a news channel or channel group to TVs.
Note

To distribute an IPTV news channel group to TVs, make sure the TVs are registered in PMS.

Registering IPTV channels

Register a news channel.

1 Click TV Management > Channel Management > Channels from the menu bar at the top.

) Click Add below the channel list.

Channel Management

Comnel it honnel o

J | No | channello~ |

[Gramaram 7] | [a]
Load

| Channel category « | Language |
50 Sports

Channel Name v

Englh

News English

(SRR i R ]

2 48
1 News

English Default

Total (3)

1
- | T I




3 Configure the settings required to add a channel from the displayed window.

3 Add Channel

1 1. Channel Number * 48

V2> Channel Name * BBF

K. Channel 17 10 || 10|, | 10|, |123
4 4. Channel Port * 8201

LY)s. Channel Categary * News v
6 6. Channel Language * English v
[D):. 2udio Delay * 100

8 3. Channel Payment * ® Free Pay

D). select EPG EPG

Enter an IPTV channel number.

Enter an IPTV channel name.

Enter the IP address of the IPTV channel.

Enter the port number of the IPTV channel.

Select News as the IPTV channel type from the dropdown list.

Select an IPTV channel language from the dropdown list.

Select whether to provide the IPTV channel for free or for a charge.

Import EPG info for the IPTV channel.

® ©¢ ©¢ ¢ 6 6 © © o

For details on EPG info, refer to the following: B Creating EPG data

4 After configuring the required settings, click OK.
— The channel will be added.

Specify the Audio Delay value used to manually sync the IPTV audio and video.
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IPTV channel group settings

Make a group of news channels.
1 Click TV Management > Channel Management > Channel List from the menu bar at the top.

) Click Add below the channel list.

Channel Management |Mwm“mmwm“ Remote Control || 1v il Hanagement |
e — - |
O | N | List Name w | Channels | Register Datew Deploy Status v | Deployed Datew | EPG view
(J 2 IPTV Channel 002 2 2014-04-23 00:32 - - EPG
1 IPTV Channel 001 2 2014-04-22 09:30 Channel_Group001 2014-04-22 09:33 EPG
1
i ==

3 Configure the settings required to add a group from the displayed window.

Channel Management I Message Management “ Information Management “ Remote Control “ TV File Management ‘
List Name : ﬂNews ‘
L2 3 o
Number + Name « Number = Mame «
1 i - 5 CNEMNe.,
0 ACE 48 BEF
-—— -
(1) Enter News as the IPTV channel group name.
0 To add a news channel to the group, select a channel from the list and click .
(3] To delete a news channel from the group, select a channel and click [<].

4 After configuring the required settings, click OK.

— A new IPTV channel group named News will be added.



Creating a recipient TV group to distribute an IPTV channel group

Channel groups are distributed by TV group.

Create a recipient group of TVs to distribute a news channel group to.
1 Click Group > Channel Group from the menu bar at the top.

) Click Add below the list of IPTV channel recipient groups.

Channel Group rosscon | o maenns o ([RERERIR
O | ne Group Name Description v Deployed Project = Deployed Date v
a 1 Channel_Group0d01 Channel Group 001

1
i ——

3 Configure the settings required to add a group from the displayed window.

Add Channel Group X
?Smup Name | News Group |

(2011 TV Models (@ 2012-2013 TV Models (0 2014-2016 TV Models

gnselected IP: 1 eelected ;p:1
| Py Room - g Py Room ~
[ 192.168.0.12 2012 = 182.168.0.13 2013
< >
?Description | News Group for buisiness rooms |

o Enter News Group as the IPTV channel recipient group name.

6 To add a TV to the group, select the IP address of a TV and click | /.
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9 To delete a TV from the group, select the IP address of a TV and click El

9 Enter a description of the IPTV channel recipient group.

4 After configuring the required settings, click OK.

— A new IPTV channel recipient group named News Group will be added.

Distributing an IPTV channel group

Distribute a news channel group to News Group.
1 Click Deploy > Deploy Channel from the menu bar at the top left.

) Select News from the displayed IPTV channel group list. Click Next.

- Click a channel group name from the list to proceed to the next step.

Deploy Channel [ Select Project > Seiact Group & Deploy.

@ Select a channel, then dick Next button.

Total (2) e |
No Channel List ~ | Channels + | Register Date ~ Group Name + | Deployed Date ~

Le] 2 Sports 3 2013-07-24 10:34

@ 1 News 3 2013-07-24 09:44

=y

3 Select News Group from the displayed IPTV channel recipient group list. Click Deploy.

— The channels in the distributed channel group are accessible from all the TVs under the selected IPTV channel recipient
group.

— The Deploy button will not appear until an IPTV channel recipient group is selected.

Deploy Channel [ Select Project > Select Group & Deploy

@ Cick deploy button, then the Channel will be deployed to the selected group.

Channel List | Register Date Group Name
News 2013-07-24 09:44
Tota ) o I |
| Mo | Group Name v Deployed Date v | Deployed Channel List v

o 2 Sports Group

@ 1 News Group

=




Note

Check to make sure that the IPTV channel group has been distributed properly, using the following methods:
+ Click Deploy > Channel Deploy List on the left side of the page. Check that the News channel group is in the list of distributed channel groups.

« Turn off the TVs in VIP rooms and then turn on again. Check that the distributed news channels are displayed on the TVs. TVs update TV
information, such as the channel list and firmware version, while the power is turning on. Make sure to turn off the power and then on again.

Weather application auto-run menu settings

Using the MyApp Type layout, create an auto-run menu page to make a specified TV application run automatically.

In this section, learn how to make the weather application run automatically by creating a menu page named Apps and then
selecting the created menu from a TV widget.

First, information on the application list saved on a TV will need to be registered in LSS and then distributed to the other TVs.

Note

The menu to automatically run a TV application using MyApp Type is only available on TVs released in 2013.

Copying application list info saved ona TV

1 Connect a destination USB memory device to the TV.
) TurnontheTV.

3 Press Mute > 1>1>9>ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.
4 Select Network > Apps Edit from the TV default settings menu.
5 When alist of applications appears, select More Apps.

6 When the application configuration page appears, select Options > Clone TV to USB.
— Files that contain information on the TV application list will be copied to the USB memory device.

— Remember the location of the weather application on the list. The location is needed when configuring auto-run settings.

Note

Assume that the weather application is the second item on the list.

7 After the information is copied, turn off the TV and then on again.



Tutorial

Uploading copied TV application list info to LSS

1 Connect the USB memory device that contains copied information on the TV application list to the computer.
Access the LSS webpage.
Click TV Management > TV File Management > TV Configuration from the menus at the top of the LSS page.

Click Add below the list of TV configuration files.

o AW N

Configure the settings required to add a TV configuration file from the displayed window.

— Using the file upload option, upload the files that contain information on the TV application list.

Note

For details on how to configure settings from the window used to add TV configuration files, refer to the following: ~ » Adding TV configuration files

6 After configuring the required settings, click OK.

— After files are uploaded successfully, the TV application list information will be automatically distributed to the TV models
that were specified in the window used to add configuration files.

"g Note

Using LSS logs, check to ensure that the files have been distributed successfully to TVs. For details on how to view distribution logs for TV
configuration files, refer to the following: B Checking the result of TV configuration file distribution
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Tutorial

Creating a TV application auto-run menu

1 Import a project to create an auto-run menu to the LSS page.
Note
For details on how to import a project, refer to the following:  » Loading/deleting a project
) Create a new menu page named Apps.
— To use a previously created menu page, select the desired menu page.
Note

5
6

For details on creating and editing a menu page, refer to the following: ~ » Managing user menus

Select MyApp Type from the page layouts found in the menu page configuration screen.

- Template type where MyApp Type is found varies for each widget type.

Select 2nd from the dropdown list showing the arrangement of TV applications.

- The weather application that is the second item on the TV application list will be set to run automatically.

Select Template | EMenutistiye | | B Rl | | D Othertipe |
Menu Contents Type Bill Type MyApp Type
4 3 3 - = P P i
i T H — H — i
< T I ‘s I T T | | B E
] g | E T r | H g
® © 5} ) 5} ) e [ e i e

umsemnw

To save the changes, click Save.

Distribute the project.

Note

7 Select Apps from the widget menus on the TV to check to ensure that the weather application runs automatically.

For details on how to distribute a project, refer to the following: ~ » Distributing a project
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Changing the arrangement of TV applications

Customize the arrangement of TV applications according to your preference.

"g Note

+ To apply a new arrangement of applications to the application auto-run menu, copy and then distribute the list information again.

« The arrangement of applications shown in the application section of the default page will also be updated according to the customized order.

e 7 =

WESHILLA
|

THESHILLA

Hotel Guest
Information Service

Attractions

Icon6

Appé
Left/Right Enter

1 TurnontheTV.

) Press Mute > 1>1>9 > ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.

Select Network > Apps Edit from the TV default settings menu.

S~ w

When a list of applications appears, select More Apps.
When the application configuration page appears, select Options > Edit My Apps.
Select an application to rearrange from the displayed My Apps list.

Move the application to the desired location using the arrow buttons on the remote control and then press ENTER.

coO N oy o

After rearranging applications as desired, turn off the TV and then on again.



Using the IPTV function only

To only use the IPTV function without creating a project in LSS, obtain a free license to access the IPTV channel-related menus
and the function to distribute channels without time limits.

1 Onthe LSS screen, click License > License List > Free License and obtain a IPTVOnly type free license.

@ Note

For further details on obtaining a free license, refer to the following:  » Using a free license

7 Turn on the TV where you will use the IPTV function, then connect a USB storage device to the TV.

3 Press Mute > 1>1>9>ENTER on the Samsung remote control to enter factory mode.

— Inreset mode, the initial TV settings menu appears.
4 Select Widget from the TV default settings menu.
5 Select ServerURL Setting from the widget settings menu.
When the LSS IP configuration screen appears, delete all the address input fields. Next, select Done.
Press Return on the Samsung remote control to return to the initial TV setup menu.

Select Cloning from the TV default settings menu.

O o0 N O

Select Clone USB to TV to save TV information onto the USB storage device.
10 Connect the USB storage device containing the saved TV information to the LSS.
11 Onthe LSS screen, click TV Management > Channel Management > Channel List.

12 Select a channel and click Clone To USB.

— Information about the selected IPTV channel group will be saved as a zipped file.

13 Unzip the downloaded IPTV channel group information file.

— The HospitalityBrowser folder will appear.
14 Copy the HospitalityBrowser folder as a child folder under the TV information folder on the USB storage device.
15 Connect the USB storage device containing the copied IPTV channel group information to the TV.
16 Press Mute > 1> 1> 9> ENTER on the Samsung remote control to enter factory mode.
17 Select Cloning from the TV default settings menu.

18 Select Clone USB to TV to save the channel information from the USB storage device to the TV.

— Use the IPTV channel function on the TV.
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Data backup

Back up database and data files in LSS.

Database backup and restore

Back up or restore database in LSS using the CUBRID manager program.

Database backup

1 Download and install the latest version of the CUBRID manager install file from the following path:

- http://ftp.cubrid.org/CUBRID_Tools/CUBRID_Manager/
) After the installation is complete, run the program.

3 Right-click on the HOTELTV database name and select Manage Database > Backup Database.
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Data backup

4 Select the Delete unnecessary log-archives checkbox. Click OK.

2
< o ol s
Backup Information Back Ewhﬂnﬂnaﬁnnl

Database name:  hoteltw

Volume name: hoteltv_backup_h{

Backup level:  [Leveld -
Backup directory:  C:\CUBRID! databases\hotelt\backup Browse...

Parallel backup: 0 E

[#] Check the database consistency

[] Delete unnecessary log-archives

Compress backup volumes

| OK I Cancel

5 Specify the destination backup folder. Click OK.
— The HOTELTV database will start the backup process.

Database restore

1 Torestore the HOTELTV database, run the CUBRID manager.

) Right-click on the HOTELTV database name and select Stop Database.
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Data backup

3 Go to the path C:\CUBRID\databases\hoteltv and delete all files except the lob folder. The path is created in the C drive when
CUBRID is installed.

Note
Assume that the path to the CUBRID folder is the C drive.

4 Right-click on the HOTELTV database name and select Manage Database > Restore Database.

e
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File Edit Tools Action Help
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Deselect the Select restore date and time checkbox in the database restore window.
Select the Select available backup information checkbox.

Select Level O file.

Click Browse... to select a backup file to be restored.

Click OK to start database restore.
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Data backup

LSS data file backup

Back up channel information, content files, TV firmware and TV license data files saved in LSS.
1 Goto C:\HotelTV\htdocs\data, which is the destination folder created in the C drive when LSS is installed.

Note

Assume that the path to the HOTELTV folder is the C drive.

'\ channel
W files

L firm

! license
channel This folder holds channel setting files including the ChannelMap.xml file.
files This folder holds content files that are used when editing a project.
firm This folder holds TV firmware files.

license This folder holds TV License Key files.

) Zip the folders you want to back up and save the folders to the desired location.



Troubleshooting

In the occurrence of a problem when using LSS, resolve the problem according to the troubleshooting guide below.

Resolving a failure involving message transmission, TV
power control or channel list transmission

If the function to send messages, control the power supply to TVs or send channel lists does not work properly, restart Socket,
register the Apache in firewalls or disable firewalls to resolve the issue.

Restarting Socket monitoring

1 Torestart Socket monitoring, right-click on the ' = icon on the computer task bar.

AutoReStart

E,I._.I,._. ':"“I'
SENVILE Slall

Service Restart

Service Stop

E  Exit

) If the Service Start item is active, click Service Restart.

— Socket monitoring will restart.
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When the Socket monitoring icon is not found on the task bar

1 Go to C:\HotelTVAhtdocs\bin, which is the destination folder created in the C drive when LSS is installed.

Note

Assume that the path to the HOTELTV folder is the C drive.

7 Double-click HotelCMSMonitor.exe.

— When the icon appears on the task bar, restart Socket monitoring.

Registering the Apache server in firewalls

If there is an issue with transmitting messages/channel lists or a problem with TV power control persists after restarting Socket
monitoring, register the Apache server in the inbound and outbound rules of Windows Firewall.

Adding inbound rules

1 Onthe computer, select Start > Control Panel > Windows Firewall > Advanced settings.

Note

The Control Panel path is based on the icon view mode.

) Select Inbound Rules, and click New Rule.
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3 Select Program, and click Next.

Rule Type
Select the type of firewall rule 1o crate.

Steps:
o Fule Tyne What type of rule would you like fo create?
@ Program
@ Action Program
Rule that sontrals connestions for a program.
o Profie
Port
@ MName Rule that controls connections for a TCP or UDP port,
© Predefined:
[BranchCache - Content Retreval Uses HTTP) =
Fule that contrals connections for a Windows experience.
© Custom
Customn rule.

Learn more about rule tupes

[ <Back |[CNext> J [ Cancel ]

4 Select This program path, and click Browse.

|

Program
Specify the full program path and executable name of the program that this rule matches,

Steps:
» Fule Type Does this rule apply to all programs or a specific program?
» Program
@ Action Al programs

Rule applies 1o all connections on the computer that match ather rule properties,
@ Profile
@ Name © This proaram path:

| S
Example ::WpathEmgram‘ExE
#ProgramFiles %Whrowseritbrowser exe

Learn more about specifying programs

[ Back | [ Mest> ] [ Cancel ]

5 Goto C:\HotelTW\Server\Apache\bin, which is the destination folder of Apache when LSS is installed.

Note

Assume that the path to the HOTELTV folder is the C drive.
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6  Select httpd.exe, and click Next.

Program
Specity the full pragram path and executable name of the program that this rule matches

Steps:
@ Fule Type Daes this rule apply to all programs or @ specific program?
@ Program
@ fction © Al procrams
Fule applies to all connections on the computer that match other rule properties,
@ Profile
@ Name (@ This proaram path:
%Sy stemDrive % WHolel TV S arve i Ap inhitpd, exe [Browse
Example citpathitprogram exe

#ProgramFiles %Whrowseribrowser, exe

Learn more about specifying programs

[ Back | Mext> | [ Cancel ]

7 Select Allow the connection, and click Next.

Action
Specify the action 10 be taken when a connection matches the conditions specified in the nle,

Steps:

@ Fule Type What action should be taken when a connection matches the specified conditions?

o Frogram

- © Allow the connection
@ Action This includes connections that are protected with IPssc as well as those are not
o Profi
roe (©) Allow the connection if it is secure

o MName This includes enly connections that have been authenticated by using IPsec, Connections

il be sccured using fe sefings n Psec praperties and ies n e Cannection Securty
Ule node

©) Block the connection

Learn more about actions

[ Back | [ Mest> ] [ Cancel |

§ Select the Domain, Private and Public checkboxes. Click Next.

Profile
Specify the profiles for which this rule applies,

Steps:
o Fule Type When does this rule apply?
» Program
o fction ] Domain
) Applies when a computer is connected to its corporate damain
w Profile
@ Mame iz
Applies when a computer Is connected to a private network location,
Public

Applies when a computer is connected to a public netwark lncation,

Learn more about profiles
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O Enter a rule name and description. Click Finish.

Steps:

Fule Type
Program
Action

Profile

Narne

Specify the name and description of this mle,

Mame!

Apache_Inbound_Rule

Description {optional):

Inbound rule for firewsall,

[

< Back

J[_Finish_] [

Cancel

]

Name

Adding outbound rules

1 Onthe computer, select Start > Control Panel > Windows Firewall > Advanced settings.

7 Select Outbound Rules, and click New Rule.

3

Fil

Action View Help

g i )

m Security Rules
» &, Monitoring

1@ BranchCache Content Retrieval (HTTP-O...

1@ Connect to o Network Projector (WSD
1@ Connect to o Network Projector (WSD
1@ Connectto s Network Projector (WSD

Name

ranchCache Hosted Cache Client (HTT...
ranchCache Hosted Cache Server(HTTP...

1@ BranchCache Peer Discovery (WSD-Out)

Connectto 2 Network Projector (TCP-Out)
Connectto 2 Network Projector (TCP-Out)
Connectto a Network Projector (WSD Ev...

Connectto a Network Projector (WSD-Ohu.

Group . Profile
BranchCache - Content Retr.
BranchCache - Hosted Cach,
BranchCache - Hosted Cach...
Branchtache - Pesr Discove..
Connect to a Netuork Proje
Connect to a Netuork Proje
Connect to a Netuork Proje
Connect to a Netuork Proje
Connect to a Netuork Proje
Connect to a Netwark Pr
Connect to a Network Proje.. Al
s .

Core

9
Core Networking -
Core Networking -
Core Networking -
Core Networking -
Core Networking -
Core Netwarking -
Core Networking -
Core Networking -
Core Networking -
Core Networking -
Core Networking -
Core Netwarking -
Core Networking -
Core Networking -
Core Networking -

Dynamic Host Config..

Dynamnic Host Cont
Group Policy (LSASS-...
Group Policy (NP-Out)
Group Policy (TCP-0...
Intemet Group Mana...
TPHTTPS (TCP-Out)
1Pu6 ([Pr6-Out)
Multicast Listener Do...
Multicast Listener Q
Multicast Listener Rep.
Multicast Listener Rep.
Neighbor Discovery A.
Neighbor Discovery

Packet Too Big (ICMP...

Al
Core Networking Al
Core Netwerking Al
Core Networking Domain
Core Networking Domain
Core Netwarking Domain
Core Networking Al
Core Networking Al
Core Networking Al
Core Netwerking Al
Core Networking Al
Core Networking Al
Core Networking Al
Core Networking Al
Core Networking Al
Core Netwerking Al

Enabled
Mo

P Windows Firewall with Advanc] [ ]

Action
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow
Allow

D

Filter by Profile
T Fiter by State
T Filter by Group.

View
Refrech
[ ExportList...

Help

=

From this step, the same instructions used when adding inbound rules apply. Go to step 3 in the instructions on how to add

inbound rules.
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Registering communication ports

Registering a TCP port

1 Onthe computer, select Start > Control Panel > Windows Firewall > Advanced settings.

Note

The Control Panel path is based on the icon view mode.

) Select Inbound Rules, and click New Rule.

N
N T Filter by Profile »
Piate Vs Alow N 00t [ @ e orsine .
Prte s Alow N Crpror
Prite Vs Alow N Cuvon || 7 Fiterby Group. >
Prvte Yo Alow N s View y
A v Alow N oo || @ Reben
Prte Yo Alow N Chuser ]
b Ve Mlow No s :’“"““
Fwerid Private Ves Alow N CAprod o
FWGrid Private  Ves Alow N Capros
Piate Yo Alow N o
Prste s Alow N Crpror
A Ye  Alow N g
Al e Alow N oo,
Prite Vs Alow N apror
Privste Yer  Alow  No Chpror
Prite Vs Alow N Capror
Prte Yer  Alow N Chpror
Privte Yes  Alow N oo
P Ve Alow N Crpron
Prste Ve Bock N Cuuser
Prate Yo Bock M Chuser
A Ve Alw N Ay
A ve  Alow N any
Al e Alow N Ay
A v Alow N any
A e Alow N Ay
A v Alow N any
A Ve Alow N Ay
A v Alow N any
] ink HTTP. . Al Yes Alow N Ao

3 Select Port and then click Next.

(Cmrrr= S o

Rule Type
Select the type of firewall rule 1o crate.

Steps:

> b T What type of rule would you like to create?
@ Protocol and Paris
@ Action Program

Rule that controls connections for a program.
o Frofile

Port
@ MName Rule that controls connections for a TCP or UDP port,

@ Predefined:
[BranchCache - Content Retrieval (Uses HTTP) ~
Rule that contrls connections for @ Windows experience.

© Custom
Customn rule

Learn more about rule tupes

[ <Back  |[LMest> J [ Cancel ]
le

4 Select TCP and then enter 444, 30000-30005 in the Specific local ports field.
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5 Click Next.

Protocol and Ports

Specify the protocols and ports ta which this rule applies

Steps:

o Fule Type Does this rule apply ta TCP or UDP?

@ Protecel and Ports © TCP

@ fction © uop

o Frofile

® Mame Does this rule apply to all local ports or specific local ports?

© Al local ports.

© Specific local ports: 444 30000-30008
Example: 80, 443, 5000-5010

Learn more about protocol and ports

[ Back | [ Hext Iri( Cancel |

f  Select Allow the connection, and click Next.

@ rcrmorins N

Action
Specify the action 10 be taken when a connection matches the conditions specified in the nle,

Steps:
@ Fule Type What action should be taken when a connection matches the specified conditions?
@ Protocol and Peris
. © Allow the connection |
@ Action This includes connections that are protected with IPssc as well as those are not
o Profi
roe (©) Allow the connection if it is secure

o MName This includes enly connections that have been authenticated by using IPsec, Connections

il be sccured using fe sefings n Psec praperties and ies n e Cannection Securty

Ule node

©) Block the connection

Learn more about actions

[ Back | ggggd( Cancel |

7 Select the Domain, Private and Public checkboxes. Click Next.

Profile
Specify the profiles for which this rule applies,

Steps:
o Fule Type When does this rule apply?
@ Protocol and Ports
o fction ] Domain
) Applies when a computer is connected to its corporate damain
w Profile
@ Name Private
Applies when a computer Is connected to a private network location,
Public

Applies when a computer is connected to a public netwark lncation,

Learn more about profiles

Jﬁﬁ_%duﬂl_
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8  Enterarule name and description. Click Finish.

(Commrr= s

Name
Specify the name and description of this mle,

Steps:

@ Fule Type

@ Pratocal and Perts
Action

-
o Frofie Lz
-

TCP_Port LSS
Narne

Description toptional):
TCP Portfor LSS

[ Back | FEinish I.i( Cancel |

Registering a UDP port

1 Onthe computer, select Start > Control Panel > Windows Firewall > Advanced settings.

Note

The Control Panel path is based on the icon view mode.

) Select Inbound Rules, and click New Rule.

Windows Firewall with Advanced
Jaiiemictionmyvie gt i
e 2@ = BE
8 ool Advenc]
Name. Group Pofie  Ensbied  Action  Overide Prog
5 = A v Mew N cus
+ % Monitoring Al e Alw Mo CAse|=[7" Fiter by rofie »
Piste Ve Alow N 0ol 1l 7 sy sene )
Piate Ve Alow N el | e "
Pt Yes  Alow N ot iter by Group
Piate Ve Alow N Cihon View »
Al Ve Alw N Crpror Refresh
Pigte Ve Alow N Chuser .
b
FWGrid Private  Yes Alow N Capror °
PGrid Piate Ve Alow N Cipror
Piate Ve Alow  No Chpror
Piate Ve Alow N Cipror
Al e Alw N Mg
Al Ve Alow N Crpror
Piste Ve Alow N Capror
Piate Ve Alow N Cipror
Pite Ves  Alow  No Capror
Piate Ve Alow N Cipror
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Troubleshooting

3 Select Port and then click Next.

Rule Type
Select the type of firewall rule 1o crate.

Steps:
» Fule Type What type of rule would you like to create?
@ Pratocel and Perts
@ Action
Profile

Proaram
Rule that sontrals connestions for a program.
-
© Port
@ MName Rule that controls connections for a TCP or UDP port,
© Predefined:
[BranchCache - Content Retreval Uses HTTP) =
Fule that contrals connections for a Windows experience.

© Custom
Customn rule

Learn more about rule tupes

[ <Back  |[LMext> J [ Cancel ]
5]

4 Select UDP and then enter 30000-30005 in the Specific local ports field.

5 Click Next.

Protocol and Ports
Specify the protocols and parts 1o which this rule applies.

Steps:

o Fule Type Does this rule apply ta TCP or IDP?

& Protacel and Ports © TcP

& Action © upp

@ Prafile

@ Name Does this rule anply ta al local ports o specific local ports?
© Al local ports
® Specific local ports: 30000-30005

Example: 80, 443, 5000-5010

Learn more about protocel and ports

[ Back | ggégtl Cancel |

f  Select Allow the connection, and click Next.

Action
Specify the action 1o be taken when a connection matches the conditions specified in the rule.

Steps:
@ Rule Type

@ Pratocel and Ports
N @ Allow the connection
@ fction This includes connections that are protected with IPsec as well as these are not,

What action should be taken when a connection matches the specified conditions?

@ Frofle (©) Allow the connection if it is secure

@ Mame This includes gnly connections that have been authenticated by using IPsec, Connections

;\/HI\ be Eﬂ&:uv!d uzing the settings in IPsec properties and rules in the Connection Security
Ule node

©) Block the connection

Learn more about actions

[ Back | [ Hext> ([ Cancel |




Troubleshooting

7 Select the Domain, Private and Public checkboxes. Click Next.

Profile
Specify the profiles for which this rule applies.

Steps:

@ Fule Type \then does this rule apply?

@ Proweol and Paris

@ Aion oijDocse)

; Applies when a computer is connected to its corporate domain

o Profile
[7] Private

@ Mame Applies when a computer is connected to a private network location
[¥] Public

Applies when a computer is connected to  public network location

Learn more about profiles

8  Enterarule name and description. Click Finish.

Name
Specify the name and description of this nule,

Steps:

@ FRule Type
Frotocol and Ports
Action

-
-

o Frofie ames
-

UDP_Port LSS

Narne
Description (optional):
UDP Paort For LSS

[ cBack J[_Ewish I [ Cancel ]




Troubleshooting

Disabling firewalls

1 From the PC, go to Start > Control Panel > Windows Firewall > Turn Windows Firewall on or off.

) Select Turn off Windows Firewall (not recommended) under Home or work (private) network location settings.

@ » ContiolPonel » , » Customize et < [ | Scarch Contrt panet 5

Customize settings for each type of network

What are network locations?

Home orwork private) netwerk location setings
@ O Tum on Windoves Frswsl

i ]
Notify me when Windows Firewal blocks a new program

) © Tum it Windows Freal ot ecommended)

@ © TumonWindows Freval

al
(9] Notity me when Windows Firewal blocks a new program
O Tumoft Windows Frewl (ot ecommended)

[k [ G ]




If aTV cannot turn on or off, resolve the issue following the steps below.

To use the remote power control function, first enable the Virtual Standby function on the TV while in factory mode.

To enter factory mode, press Mute > 1 > 1 > 9 > Enter on the TV remote control.

— Inreset mode, the initial TV settings menu appears.

Set Widget > Virtual Standby to On from the TV default settings menu.

MAIN:Option, MODE:NONE, RES:NOSIGNAL, Standalone Menu

Widget Mode OFF
Solution Type SINC Server
ServerURL Setting

License Server IP Setting

IPTV Mode

Room Num Setting

When complate, power down TV.

Turn off the TV.

— The changes will be saved.

The remote power-on function (Wake On Lan, hereinafter WOL) is used to control a device by sending a magic packet to a
network via a UDP port.

Generally, the WOL packet operates when the network addresses of a sender device (LSS) and recipient device (TV) are set to

Class C Subnet of the same Gateway. To send the WOL packet to Class C Subnet of a different Gateway, enable UDP port forward
from the router.

If the function to turn on TVs does not work properly, contact the network administrator.

Example [f the IP address is "192.168.10.122", configure the subnet according to the following subnet addresses for each class:
= (Class A Subnet: 0.0.0.0 ~ 127.255.255.255
= (Class B Subnet: 128.0.0.0 ~ 191.255.255.255
= (Class C subnet: 192.0.0.0 ~ 233.255.255.255



Resolving a project distribution failure

If a project created in LSS cannot be distributed to TVs, resolve the issue following the steps below.

Resolve a project distribution issue by changing TV settings while in factory mode.
Press Mute > 1 > 1> 9 > Enter on a Samsung remote control to enter factory mode.

= Inreset mode, the initial TV settings menu appears.

In factory mode, select Network > Network Setup.

MAIN:Opin, MODE:NONE, RES:NOSIGNAL, Standalone Menu

SI Vendor OFF Widget

Power On Sevice
Channel

Menu 0SD

Operation

Clock

Music Mode

External Device

External Source

Bathroom Speaker

lution

When Complate, power down TV.

Select Network > Network Settings from the displayed network settings menu.

Network

Network Status
Network Settings

soft AP

AllShare Settings

Device Name [TV] Samsung




From the network settings page, select a network type (wired/wireless) and click Connect.
Select IP Settings from the displayed network connection information page.
Configure the IP settings including the IP address and subnet mask.

Select OK to save the configured IP settings.

In factory mode, select Widget > License Server IP Setting.

MAIN:Opin, MODE:NONE, RES:NOSIGNAL, Standalone Menu

Hospitality Mode Standalone  Network
SI Vendor OFF

Power On Sevice
Channel

Menu OSD

Operation

Clock

Music Mode

External Device

External Source

Bathroom Speaker

Eco Solution

Logo/Message

When Complate, power down TV.

Enter the IP address and port number of LSS. Press Enter on the remote control.

Turn off the TV.

— The changes will be saved.

After configuring the network and widget settings, check to make sure that the TV has been added to TV List in LSS.



Resolving a content file upload failure

The content file upload function uses Adobe Flash Player.

To install Flash Player on the computer, download and install the latest install file from the following website:
» http://get.adobe.com/kr/flashplayer/

Resolving a PMS info transmission failure

If a data transfer failure message appears with a delay of three seconds or longer during communication between LSS and PMS,
resolve the issue according to the following steps.

"g Note

PMS (Property Management System) refers to a hotel room management system. The system connects to LSS to provide necessary information for

hotel room management.

1 Go to C:\HotelTVAhtdocs, which is the destination folder created in the C drive when LSS is installed.

#] Note
Assume that the path to the HOTELTV folder is the C drive.

) Double-click the cms.config file, or open the file in a memo pad.

3 Set pmswaittime and widgetwaittime to a value larger than 3, which is the default value. Save the file.

— The settings will be updated.

pmswaitt ime=3
widgetwaittime=3




Resolving a port conflict

If access to LSS is not available due to a port conflict, resolve the issue according to the following steps:
1 Goto C:\HotelTW\Server\Apache\conf, which is the destination folder created in the C drive when LSS is installed.

] Note
Assume that the path to the HOTELTV folder is the C drive.

) Double-click the httpd.conf file, or open the file in a memo pad.

Listen: &llows vou to bind &pache to specific |P addresses and/or
ports, instead of the default. See also the <¥irtualHost=
directive,

Change this to Listen on specific |P addresses as shown below to
prevent dpache from glomming onto all bound |P addresses.

#l {sten 34,56, 73:80

#
# Dynamic Shared Object (D50) Support

St

3 Change the Listen 80 value on row 46.

— Avalue within the range of 81 - 3029 can be entered.

4 Save the file, and restart the Apache server.

— The settings will be updated.

Speeding up the TV boot time

The TV boot speed may vary depending on the size of content included in LSS projects. If the boot speed is slow, enable the
Virtual Standby function on the TV while in factory mode. This will speed up the boot time. For details on Virtual Standby
settings, refer to the following:  » Checking the Virtual Standby settings

@ Note

If the Virtual Standby function is set to ON, power consumption can increase.


textanchor:008_LSS_ENG.indd:_IPHL_Virtual Standby setting check

Resolving aTV time error

1 Goto C:\HotelTV, which is the destination folder created in the C drive when LSS is installed.

#) Note
Assume that the path to the HOTELTV folder is the C drive.

) Open the php.ini file.

3 Change "date.timezone="under [Date] to "date.timezone=continent/city" in the file.

nn

— Remove ";" in front of date.timezone.

fvﬁ Note

To find the time zone name for a continent/city, go to the following link. Select a continent from the link, and then select a city to set the time
zone. http://www.php.net/manual/en/timezones.php

Example The following is an example of the time zone set to Asia/Hong Kong.

:::::::::::::::::::

:::::::::::::::::::

[Date]

.J_D&u.uﬁ_t.hu.&ml_t_tmmu.el used by the date functions
date.timezone =AsiasHona_Kong

;date.default_latitude = 31.7EET
;date.default_longitude = 35, 2333

;date.sunrise_zenith = 90,583333
;date. sunset_zenith = 90, 583333

[
o f
it

ilter]
ilter.default = unsafe_raw
ilter.default_flags =

4 Save the php.ini file. Restart the computer or Apache to update the settings.



Troubleshooting

Resolving weather info errors

If the message "Network Not Available" appears after you save weather info settings, follow the below steps to resolve the issue:
1 Onthe PC, click the Start button, enter "cmd" in the run box, and then press Enter on the keyboard.

7 Enter "ping -n 1-w 1000 samsungmobile.accu-weather.com" in the cmd window.

3 Ifamessage appears that the requested time has expired or if the loss rate appears to be high, contact the Internet service
provider or check the Internet cable connections on your computer.

Resolving errors when running EPG Broker

If an issue occurs when you run EPG Broker, it is possible an anti-virus program caused a registry conflict when the LSS program
was installed. Disable firewalls, close anti-virus programs, and then install the LSS program again.

Disabling firewalls
1 From the PC, go to Start > Control Panel > Windows Firewall > Turn Windows Firewall on or off.

7 Select Turn off Windows Firewall (not recommended) under Home or work (private) network location settings.



Open Source
Announcement

To send inquiries and requests for questions regarding open sources, contact Samsung via Email (oss.request@samsung.com).

m This product uses some software programs which are distributed under the GPL/LGPL.

m This product uses some software programs which are distributed under the Codelgniter License.

GPL software: CUBRID
LGPL software : PHPExcel

GNU GENERAL PUBLIC LICENSE

Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc.
51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General
Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all
its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose
authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License
instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure
that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source
code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you
can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the
rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it. For
example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you
have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know
their rights.



We protect your rights with two steps:

(1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify
the software. Also, for each author's protection and ours, we want to make certain that everyone understands that there is no
warranty for this free software.

If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original,
so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents.

We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the
program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not
licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0) This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be
distributed under the terms of this General Public License. The “Program’, below, refers to any such program or work, and a “work
based on the Program” means either the Program or any derivative work under copyright law: that is to say, a work containing the
Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation
is included without limitation in the term “modification”) Each licensee is addressed as “you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of
running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on
the Program (independent of having been made by running the Program). Whether that is true depends on what the Program
does.

1) You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided that you
conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all
the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of
this License along with the Program. You may charge a fee for the physical act of transferring a copy, and you may at your option
offer warranty protection in exchange for a fee.

2) You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and
copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these
conditions:

a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any
part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such
interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a

notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under
these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does

not normally print such an announcement, your work based on the Program is not required to print an announcement.)



These requirements apply to the modified work as a whole.

If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and
separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as
separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the
distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole,
and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to
exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the
Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3) You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the
terms of Sections 1 and 2 above provided that you also do one of the following:

a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of
Sections 1 and 2 above on a medium customarily used for software interchange; or,

b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost
of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be
distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

¢) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is
allowed only for noncommercial distribution and only if you received the program in object code or executable form with such
an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work,
complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus
the scripts used to control compilation and installation of the executable. However, as a special exception, the source code
distributed need not include anything that is normally distributed (in either source or binary form) with the major components
(compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies
the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent
access to copy the source code from the same place counts as distribution of the source code, even though third parties are not
compelled to copy the source along with the object code.

4) You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt
otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this
License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated
so long as such parties remain in full compliance.

5) You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to
modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License.
Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this
License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based onit.

6) Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license
from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose
any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing compliance
by third parties to this License.

7) If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent
issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this
License, they do not excuse you from the conditions of this License.



If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations,
then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free
redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could
satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is
intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity

of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which

is implemented by public license practices. Many people have made generous contributions to the wide range of software
distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or
she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8) If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces,
the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation
excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this
License incorporates the limitation as if written in the body of this License.

9) The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such
new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to
it and “any later version’, you have the option of following the terms and conditions either of that version or of any later version
published by the Free Software Foundation.

If the Program does not specify a version number of this License, you may choose any version ever published by the Free
Software Foundation.

10) If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to
the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software
Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of
all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11) BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER
PARTIES PROVIDE THE PROGRAM “AS IS"WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE
RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU
ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12) IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR

ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR
DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR
INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR
LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN
IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS



How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to
make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively
convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to where the full notice is
found.

<one line to give the program's name and a brief idea of what it does.>

Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as
published by the Free Software Foundation; either version 2 of the License, or(at your option) any later version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

See the GNU General Public License for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software
Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY NO WARRANTY; for details
type ‘show w.

This is free software, and you are welcome to redistribute it under certain conditions; type ‘show c’for details.

The hypothetical commands ‘show w’and ‘show ¢’ should show the appropriate parts of the General Public License. Of course, the
commands you use may be called something other than ‘show w’and ‘show c’; they could even be mouse-clicks or menu items--
whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the
program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program ‘Gnomovision’ (which makes passes at compilers) written by
James Hacker.

<signature of Ty Coon>, 1 April 1989

Ty Coon, President of Vice



This General Public License does not permit incorporating your program into proprietary programs.

If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library.
If this is what you want to do, use the GNU Lesser General Public License instead of this License

GNU LESSER GENERAL PUBLIC LICENSE

Version 2.1, February 1999

Copyright (C) 1991, 1999 Free Software Foundation, Inc.
51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, version 2,
hence the version number 2.1.]

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General
Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the software is free for
all its users.

This license, the Lesser General Public License, applies to some specially designated software packages--typically libraries--of

the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you first think carefully
about whether this license or the ordinary General Public License is the better strategy to use in any particular case, based on the
explanations below.

When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed to make
sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that you receive
source code or can get it if you want it; that you can change the software and use pieces of it in new free programs; and that you
are informed that you can do these things.

To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to surrender
these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or if you modify it.

For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that we
gave you. You must make sure that they, too, receive or can get the source code.

If you link other code with the library, you must provide complete object files to the recipients, so that they can relink them with
the library after making changes to the library and recompiling it. And you must show them these terms so they know their
rights.

We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives you
legal permission to copy, distribute and/or modify the library.

To protect each distributor, we want to make it very clear that there is no warranty for the free library.

Also, if the library is modified by someone else and passed on, the recipients should know that what they have is not the original
version, so that the original author's reputation will not be affected by problems that might be introduced by others.

Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a company
cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. Therefore, we insist
that any patent license obtained for a version of the library must be consistent with the full freedom of use specified in this
license.



Most GNU software, including some libraries, is covered by the ordinary GNU General Public License.

This license, the GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary
General Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs.

When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally speaking
a combined work, a derivative of the original library. The ordinary General Public License therefore permits such linking only if the
entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria for linking other code
with the library.

We call this license the “Lesser” General Public License because it does Less to protect the user's freedom than the ordinary
General Public License. It also provides other free software developers Less of an advantage over competing non-free programs.
These disadvantages are the reason we use the ordinary General Public License for many libraries. However, the Lesser license
provides advantages in certain special circumstances.

For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so that it
becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more frequent case is that
a free library does the same job as widely used non-free libraries. In this case, there is little to gain by limiting the free library to
free software only, so we use the Lesser General Public License.

In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a large body
of free software. For example, permission to use the GNU C Library in non-free programs enables many more people to use the
whole GNU operating system, as well as its variant, the GNU/Linux operating system.

Although the Lesser General Public License is Less protective of the users’ freedom, it does ensure that the user of a program that
is linked with the Library has the freedom and the wherewithal to run that program using a modified version of the Library.

The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference between
a“work based on the library” and a “work that uses the library”. The former contains code derived from the library, whereas the
latter must be combined with the library in order to run.

TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0) This License Agreement applies to any software library or other program which contains a notice placed by the copyright
holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also called
“this License”). Each licensee is addressed as “you’”.

A“library” means a collection of software functions and/or data prepared so as to be conveniently linked with application
programs (which use some of those functions and data) to form executables.

The “Library’, below, refers to any such software library or work which has been distributed under these terms. A “work based
on the Library” means either the Library or any derivative work under copyright law: that is to say, a work containing the Library
or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another language. (Hereinafter,
translation is included without limitation in the term “modification”)

“Source code” for a work means the preferred form of the work for making modifications to it. For a library, complete source code
means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control
compilation and installation of the library.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of
running a program using the Library is not restricted, and output from such a program is covered only if its contents constitute

a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that is true depends on what
the Library does and what the program that uses the Library does.

1) You may copy and distribute verbatim copies of the Library’s complete source code as you receive it, in any medium, provided
that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep
intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of this License along with



the Library.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange
for a fee.

2) You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and copy and
distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

a) The modified work must itself be a software library.
b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any change.
¢) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.

d) If afacility in the modified Library refers to a function or a table of data to be supplied by an application program that uses
the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort to ensure that,
in the event an application does not supply such function or table, the facility still operates, and performs whatever part of its
purpose remains meaningful. (For example, a function in a library to compute square roots has a purpose that is entirely well-
defined independent of the application. Therefore, Subsection 2d requires that any application-supplied function or table used
by this function must be optional: if the application does not supply it, the square root function must still compute square roots.)
These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Library,
and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply
to those sections when you distribute them as separate works.

But when you distribute the same sections as part of a whole which is a work based on the Library, the distribution of the whole
must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and
every part regardless of who wrote it. Thus, it is not the intent of this section to claim rights or contest your rights to work written
entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the
Library. In addition, mere aggregation of another work not based on the Library with the Library (or with a work based on the
Library) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3) You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of the
Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU General Public
License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU General Public License

has appeared, then you can specify that version instead if you wish.) Do not make any other change in these notices. Once
this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU General Public License applies to all
subsequent copies and derivative works made from that copy.

This option is useful when you wish to copy part of the code of the Library into a program that is not a library.

4) You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable form
under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding machine-readable
source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software
interchange.

If distribution of object code is made by offering access to copy from a designated place, then offering equivalent access to copy
the source code from the same place satisfies the requirement to distribute the source code, even though third parties are not
compelled to copy the source along with the object code.

5) A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being
compiled or linked with it, is called a “work that uses the Library”. Such a work, in isolation, is not a derivative work of the Library,
and therefore falls outside the scope of this License.

However, linking a “work that uses the Library” with the Library creates an executable that is a derivative of the Library (because it
contains portions of the Library), rather than a “work that uses the library”.

The executable is therefore covered by this License. Section 6 states terms for distribution of such executables.

When a “work that uses the Library” uses material from a header file that is part of the Library, the object code for the work may
be a derivative work of the Library even though the source code is not. Whether this is true is especially significant if the work can



be linked without the Library, or if the work is itself a library. The threshold for this to be true is not precisely defined by law.

If such an object file uses only numerical parameters, data structure layouts and accessors, and small macros and small inline
functions (ten lines or less in length), then the use of the object file is unrestricted, regardless of whether it is legally a derivative
work. (Executables containing this object code plus portions of the Library will still fall under Section 6.)

Otherwise, if the work is a derivative of the Library, you may distribute the object code for the work under the terms of Section 6.
Any executables containing that work also fall under Section 6, whether or not they are linked directly with the Library itself.

6) As an exception to the Sections above, you may also combine or link a“work that uses the Library” with the Library to produce
a work containing portions of the Library, and distribute that work under terms of your choice, provided that the terms permit
modification of the work for the customer’s own use and reverse engineering for debugging such modifications.

You must give prominent notice with each copy of the work that the Library is used in it and that the Library and its use are
covered by this License. You must supply a copy of this License. If the work during execution displays copyright notices, you must
include the copyright notice for the Library among them, as well as a reference directing the user to the copy of this License. Also,
you must do one of these things:

a) Accompany the work with the complete corresponding machine-readable source code for the Library including whatever
changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is an executable linked
with the Library, with the complete machine-readable “work that uses the Library", as object code and/or source code, so that the
user can modify the Library and then relink to produce a modified executable containing the modified Library. (It is understood
that the user who changes the contents of definitions files in the Library will not necessarily be able to recompile the application
to use the modified definitions.)

b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at run time a
copy of the library already present on the user’s computer system, rather than copying library functions into the executable, and
(2) will operate properly with a modified version of the library, if the user installs one, as long as the modified version is interface-
compatible with the version that the work was made with.

¢) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified in
Subsection 6a, above, for a charge no more than the cost of performing this distribution.

d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to copy the
above specified materials from the same place.

e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy. For an
executable, the required form of the “work that uses the Library” must include any data and utility programs needed for
reproducing the executable from it. However, as a special exception, the materials to be distributed need not include anything
that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the
operating system on which the executable runs, unless that component itself accompanies the executable.

It may happen that this requirement contradicts the license restrictions of other proprietary libraries that do not normally
accompany the operating system. Such a contradiction means you cannot use both them and the Library together in an
executable that you distribute.

7) You may place library facilities that are a work based on the Library side-by-side in a single library together with other library
facilities not covered by this License, and distribute such a combined library, provided that the separate distribution of the work
based on the Library and of the other library facilities is otherwise permitted, and provided that you do these two things:

a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other library
facilities. This must be distributed under the terms of the Sections above.

b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and explaining where
to find the accompanying uncombined form of the same work.

8) You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this License. Any
attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically terminate your
rights under this License. However, parties who have received copies, or rights, from you under this License will not have their
licenses terminated so long as such parties remain in full compliance.



9) You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to
modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this License.
Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your acceptance of this
License to do so, and all its terms and conditions for copying, distributing or modifying the Library or works based on it.

10) Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license from
the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may not impose
any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible for enforcing compliance
by third parties with this License.

11) If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent
issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this
License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your
obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Library
at all. For example, if a patent license would not permit royalty-free redistribution of the Library by all those who receive copies
directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from
distribution of the Library. If any portion of this section is held invalid or unenforceable under any particular circumstance, the
balance of the section is intended to apply, and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity

of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system which

is implemented by public license practices. Many people have made generous contributions to the wide range of software
distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or
she is willing to distribute software through any other system and a licensee cannot impose that choice. This section is intended
to make thoroughly clear what is believed to be a consequence of the rest of this License.

12) If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted interfaces,
the original copyright holder who places the Library under this License may add an explicit geographical distribution limitation
excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this
License incorporates the limitation as if written in the body of this License.

13) The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from time
to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or
concerns.

Each version is given a distinguishing version number. If the Library specifies a version number of this License which applies to

it and “any later version’, you have the option of following the terms and conditions either of that version or of any later version
published by the Free Software Foundation. If the Library does not specify a license version number, you may choose any version
ever published by the Free Software Foundation.

14) If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible with
these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the
Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving
the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

15) BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO THE EXTENT PERMITTED
BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE
THE LIBRARY “AS IS"WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY
AND PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL
NECESSARY SERVICING, REPAIR OR CORRECTION.

16) IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY
OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES,



INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE
THE LIBRARY (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED
BY YOU ORTHIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH HOLDER OR
OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Libraries

If you develop a new library, and you want it to be of the greatest possible use to the public, we recommend making it
free software that everyone can redistribute and change. You can do so by permitting redistribution under these terms (or,
alternatively, under the terms of the ordinary General Public License).

To apply these terms, attach the following notices to the library. It is safest to attach them to the start of each source file to most
effectively convey the exclusion of warranty; and each file should have at least the “copyright”line and a pointer to where the full
notice is found.

one line to give the library’s name and an idea of what it does.

Copyright (C) year name of author

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as
published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

See the GNU Lesser General Public License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free Software
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

Also add information on how to contact you by electronic and paper mail.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer” for the
library, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the library ‘Frob’ (a library for tweaking knobs) written by James Random
Hacker.

Signature of Ty Coon, 1 April 1990 Ty Coon, President of Vice

That's all there is to it!

Codelgniter License Agreement



Copyright (c) 2008 - 2014, EllisLab, Inc.

All rights reserved.

This license is a legal agreement between you and EllisLab Inc. for the use of Codelgniter Software (the "Software"). By obtaining
the Software you agree to comply with the terms and conditions of this license.

Permitted Use

You are permitted to use, copy, modify, and distribute the Software and its documentation, with or without modification, for any
purpose, provided that the following conditions are met:

A copy of this license agreement must be included with the distribution.
Redistributions of source code must retain the above copyright notice in all source code files.

Redistributions in binary form must reproduce the above copyright notice in the documentation and/or other materials provided
with the distribution.

Any files that have been modified must carry notices stating the nature of the change and the names of those who changed
them.

Products derived from the Software must include an acknowledgment that they are derived from Codelgniter in their
documentation and/or other materials provided with the distribution.

Products derived from the Software may not be called "Codelgniter", nor may "Codelgniter" appear in their name, without prior
written permission from EllisLab, Inc.

Indemnity

You agree to indemnify and hold harmless the authors of the Software and any contributors for any direct, indirect, incidental, or
consequential third-party claims, actions or suits, as well as any related expenses, liabilities, damages, settlements or fees arising
from your use or misuse of the Software, or a violation of any terms of this license.

Disclaimer of Warranty

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED
TO, WARRANTIES OF QUALITY, PERFORMANCE, NON-INFRINGEMENT, MERCHANTABILITY, OR FITNESS FOR A PARTICULAR
PURPOSE.

Limitations of Liability

YOU ASSUME ALL RISK ASSOCIATED WITH THE INSTALLATION AND USE OF THE SOFTWARE. IN NO EVENT SHALL THE AUTHORS
OR COPYRIGHT HOLDERS OF THE SOFTWARE BE LIABLE FOR CLAIMS, DAMAGES OR OTHER LIABILITY ARISING FROM, OUT OF, OR
IN CONNECTION WITH THE SOFTWARE. LICENSE HOLDERS ARE SOLELY RESPONSIBLE FOR DETERMINING THE APPROPRIATENESS
OF USE AND ASSUME ALL RISKS ASSOCIATED WITH ITS USE, INCLUDING BUT NOT LIMITED TO THE RISKS OF PROGRAM ERRORS,
DAMAGE TO EQUIPMENT, LOSS OF DATA OR SOFTWARE PROGRAMS, OR UNAVAILABILITY OR INTERRUPTION OF OPERATIONS.
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